記事内でPHPを実行する「Exec-PHP」


記事内で、PHPのコードを実行したい場合も多いかと思います。
そんなときに便利なプラグインがこちら。

Exec-PHP

設定についてですが、プラグインを有効化後、 管理画面→設定→Exec-PHP に入ると、
Execute PHP code in text widgets という文字の横にチェックボックスがあります。
こちらにチェックを入れて save check のボタンを押すと、
ウィジェットの、任意のテキストと HTMLを入力できる「テキスト」内でもPHPが使えるようになります。

このままでも使用できるのですが、
プロフィールの「ビジュアルリッチエディターを使用しない」にチェックが入っている場合、
記事を新規投稿するときに、

Exec-PHP WYSIWYG Conversion Warning. ・・・・

という警告が表示されています。
管理画面→ユーザー→あなたのプロフィール に入り、
Disable WYSIWYG Conversion Warning の横にあるチェックボックスをチェックし、
プロフィールを更新 を押すと警告が表示されなくなります。

タグ: , ,

記事公開日:
最終更新日:

コメントを残す

*上記画像の英数字を入力してください。